How to set up SSO in SharePoint

How to set up SSO in SharePoint

Was having problem setting up SSO.  Keep getting error.  Here is what I did to get it setup properly (I notice there are post out there in the internet, but some are missing some information:

1.  Create a domain service account (ex: moss_sso)

2. OPTIONAL: Create a domain security group with “Global” and with “Group Type” as “Security”.  Add the moss_sso service account to this group.  (you can create two group, one for Definition Administrator and one for SSO Administrator)

3. Add the domain services account (or security group) to the local administrators group on all SharePoint servers.

4. Log into the server that is running “Central Administration” web site.

5. Navigate to “Central Administration -> Operations -> Service Accounts” and double check the “Single Sign-on Service” credentials, set the services to run from the domain services account (moss_sso).

6. Also add the domain service account used to run the service to the Farm’s administrators group

7. Start the “Microsoft Single Sign-on Service” in the Windows Services under Manage.  Set the services to start “Automatic”.  Run the service under a domain service account (moss_sso).  Start the service. (if not already started)

6. Repeat 6 on all server except server which will only act as WFE.

7. In SQL, set the domain service account (moss_sso) running the Microsoft SSO service has the following roles assigned on SQL Server:  dbcreator and securityadmin

8. Log into the server that is running “Central Administration” web site.  NOTE:  make sure you log using the New Services account (moss_sso)!!!  This is the part that give the issue when I was trying to set this up.

12.Navigate to “Central Administration -> Operations -> Manage Single Sign-On -> Manage Server Settings” to setup SSO for SharePoint

12.1 Single Sign-On Administrator Account: Domain Group or the Services account moss_sso

12.2 Enterprise Application Definition Administrator Account: Domain Group or the Services account moss_sso

12.3 Database Server Name (use netbios naming convention)

12.4 Database Name

12.5 Timeout settings (I used Default)

12.6 Ok.

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: